NPM 在全球范围内出现“ERR!418 我是茶壶”错误

阿里云高性能服务器2折起 !>>>  

npm

NPM JavaScript 包管理器的用户遇到了一个奇怪的错误,当他们尝试更新或安装新的JavaScript / Node.js包时,他们的控制台和应用程序每都会发出“ERR!418 我是茶壶”的消息。并且,世界各地的JavaScript 开发者都收到了这样的提示。

只有代理服务器的用户受到影响

不过,该错误不会影响所有用户,只会影响代理服务器后面的用户。 尽管如此,大量开发人员仍然受到影响,因为大多数大型开发公司通常使用代理来管理和控制内部网络流量。

这个错误的原因是一些代理服务器将端口值附加到发往 NPM 软件包注册表的请求上,导致出现类似 registry.npmjs.org:443 的 HTTP 请求,而不是r egistry.npmjs.org。

额外的端口 443 值将 NPM 注册表的服务器混淆,然后触发了 418 错误代码。

NPM 团队在七个小时后解决了这个问题,在此期间,开发人员都对这个有趣的错误代码感到惊慌和惊讶。

“ERR!418 我是茶壶”起源

“错误 418 我是茶壶”消息不是标准的服务器错误类型,这是 1998 年的一个愚人节恶作剧,距今已有 20 年了。许多开发团队在他们的应用程序中实施了“错误 418 我是茶壶”的消息作为内部笑话,通常使用这个错误来处理未知来源的错误。

原文:BleepingComputer  编译:开源中国

Be the first to comment

Leave a Reply

Your email address will not be published.


*